English
This forum is closed for posting. Please, join us in our Discord server at discord.gg/regnum. See you there!

Go Back   Champions of Regnum > English > Technical Support > Linux

Linux Technical issues under Linux platform

Reply
 
Thread Tools Display Modes
Old 12-25-2008, 03:14 PM   #1
Arafails
Baron
 
Arafails's Avatar
 
Join Date: Nov 2007
Location: Not where it looks like, to either of us.
Posts: 706
Arafails will become famous soon enough
Default $http_proxy handled incorrectly.

I was having some severe problems with my updater, and eventually tracked it down to this.

I had this variable set as per spec to a uri ( http://proxy.example.com:port/ ), and the resource updater seems to just split at the first colon, resulting in a lot of gethostbyname(http) calls, resulting predictably in failure.

After unsetting the variable on a hunch, everything worked fine.
__________________
If you can't detect sarcasm yourself, please pay attention when it's pointed out to you.
Arathael :: Wyrd Sceote :: Gwn M'gerSoul Taker, Imperial Guard of Ignis

Last edited by fudje; 12-25-2008 at 03:57 PM.
Arafails no ha iniciado sesión   Reply With Quote
Old 12-25-2008, 04:20 PM   #2
arlick
Duke
 
arlick's Avatar
 
Join Date: Jan 2007
Posts: 3,939
arlick is a jewel in the rougharlick is a jewel in the rougharlick is a jewel in the rough
Default

A quick fix try adding ip-domain to the file /etc/hosts

or you can try tsocks. Regnum (im not sure) is not able to manage proxy connection, so with that program you can proxify it.
__________________
"Nunca un científico ha quemado a un religioso por afirmar a Dios sin pruebas". Manuel Toharia
"uno empieza a darse cuenta que eso de no hacer ejercicio, comer y beber como si fuese la ultima cena y mantener la figura ya no existe...". Maryan
arlick no ha iniciado sesión   Reply With Quote
Old 12-26-2008, 10:58 AM   #3
Arafails
Baron
 
Arafails's Avatar
 
Join Date: Nov 2007
Location: Not where it looks like, to either of us.
Posts: 706
Arafails will become famous soon enough
Default

No, in fact that's incorrect. This is purely to do with the http updater. Having the environment variable set correctly was causing it to fail ro download updates, because it was trying to resolve the address of host "http" – which doesn't exist on my local network. This has been very distressing with the recent updates.

The problem stemmed from the fact the Regnum Online incorrectly does not attempt to resolve the host part of a uniform resource identifer in the http_proxy variable, but goes straight to the fallback of attempting to resolve the host part of a host:port pair (which was correct for a number of programs, mostly console web browsers, back in the mid 90s). When this (inevitably if your environment is set per spec) fails, it then simply decides it can't download anything from the update server, instead of attempting to open a direct connection. This causes, for example and variously, problems you might have had with spawning in an aquarium with the mobs hovering above you after the 1.0 update, Christmas trees and boats being displayed as untextured boxes, or item and npc names (and speech) to appear as error texts.

I have already worked around the problem and in fact provided the workaround in the first post. I have no intention of proxying the actual game traffic for any reason.
__________________
If you can't detect sarcasm yourself, please pay attention when it's pointed out to you.
Arathael :: Wyrd Sceote :: Gwn M'gerSoul Taker, Imperial Guard of Ignis
Arafails no ha iniciado sesión   Reply With Quote
Old 12-26-2008, 04:40 PM   #4
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,366
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

Thank you for your report, I'll add it to the list of known problems in the Spanish forum in case someone else needs it.
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved